본문으로 바로가기

[jQuery] 변경이력

category 웹코딩/Javascript 2013.12.12 17:54

한 동안 jQuery를 잊고 살았더니 많은 변경점들이 생겼다.


< 2013 - 12 - 12 정리>

  • jQuery가 2.x 와 1.x 의 두 가지 버전으로 나뉘어 개발이 이루어지고 있다. 2.x 버전은 IE 6,7,8 을 더이상 지원하지 않는다. 1.x 버전은 IE 6,7,8을 지원한다.
  • jQuery가 버전업이 되면서 사라지거나 변경된 점이 많다. 특히 1.9 버전대에 이르러서 과거에 만들어진 플러그인들 중에 변경점들로 인해 오작동을 일으킬수 있는 것들이 있는데 구버전의 API들과 호환성을 보장하기 위한 스크립트가 새로 생겼다. https://github.com/jquery/jquery-migrate 에서 자세한 내용을 확인할 수 있다. CDN은 <script src="http://code.jquery.com/jquery-migrate-1.2.1.js"></script>이다.


신고

'웹코딩 > Javascript' 카테고리의 다른 글

다시 공부하는 자바스크립트  (2) 2016.03.01
정규 표현식 도움말  (0) 2015.09.23
jQuery Migrate Plugin - Warning Messages  (0) 2015.09.17
jQuery 구버전과 최신버전의 혼용 - jQuery Migrate  (0) 2015.09.16
[jQuery] 에러  (0) 2013.12.19
[jQuery] 변경이력  (0) 2013.12.12

댓글을 달아 주세요

티스토리 툴바