본문으로 바로가기

[Ubuntu] 우분투 Ajaxploer(pydio) 설치

category 리눅스/Ubuntu 2013.11.12 05:51

Ajaxploer는 웹하드, FTP, 클라우드, 로컬 디스크 연결 및 삼바 연결등 다양한 방법으로 저장소를 연결할 수 있는 애플리케이션입니다. 현재는 이름이 변경되어 pydio로 불립니다.

설치전에 APM이 설치되어 있다고 가정한다.

MySQL DB생성 및 사용자 추가

pydio는 꼭 SQL 서버가 필요한 것은 아니다. 파일 시스템을 이용해서 사용할 수 도 있으며 약 50여명의 사용자들이 사용하기에 적합하다. 나의 경우에 우분투 시스템에 다른 사용자를 추가하지 않기때문에 MySQL을 사용하여 새로운 사용자들을 추가해야 한다.

MySQL 접속

mysql -u root -p

Ajaxploer DB 생성

CREATE DATABASE ajaxploer;

DB 사용자 추가 및 패스워드 설정($password에 원하는 패스워드 입력)

GRANT ALL ON ajaxploer.* TO ajaxploer@localhost IDENTIFIED BY '$password';

MySQL 새로고침

flush privileges;

mysql 종료

exit

pydio 다운로드

pydio는 다운로드하여 웹상에서 다운로드하여 설치하는 방법과 저장소를 추가하여 apt-get을 이용하여 설치하는 방법이 있는데 전자가 간편하기에 이를 이용한다.

pydio 설치 위치로 이동

cd /var/www/cloud.uzuro.com/public_html

pydio 다운로드

wget http://sourceforge.net/projects/ajaxplorer/files/ajaxplorer/stable-channel/5.0.4/ajaxplorer-core-5.0.4.zip

압축해제 및 이름 변경

unzip ajaxplorer-core-5.0.4.zip 
mv ajaxplorer-core-5.0.4 pydio

소유주 변경 및 권한 변경

sudo chown -R www-data.www-data pydio
sudo chmod -R 775 pydio

아파치 가상호스트 설정을 하고 이를 활성화한다. AllowOverride All로 설정해서 .htaccess 사용 가능하게 한다.이하 생략...

브라우저 접속 (본인은 https 설정을 했고 가상호스트의 DocumentRoot의 경로를 /var/www/cloud.uzuro.com/public_html/pydio 로 설정 했음)

https://cloud.uzuro.com/

Pydio Diagnostic Tool 설정

pydio를 사용하기에 앞서 경고 문구가 발생한 부분을 수정해준다.

PHP Output Buffer disabled

sudo vi /etc/php5/apache2/php.ini

  output_buffering = Off

Charset

sudo vi /var/www/cloud.uzuro.com/public_html/pydio/conf/bootstrap_conf.php

   define("AJXP_LOCALE", "en_US.UTF-8");
   define("AJXP_LOCALE", "");

아파치 재시작

sudo service apache2 restart

브라우저를 리로드하고 설정 화면에서 각각의 정보를 입력한다.

업로드 설정 추가

sudo vi /var/www/cloud.uzuro.com/public_html/pydio/.htaccess

  php_value upload_max_filesize 2048M
  php_value post_max_size 2000M
  php_value max_execution_time 0
  php_value max_input_time 0

업로드 설정 변경후 pydio 웹브라우저 접속

사용자 > 설정 > Global Configurations > Core Configs > Uploaders Options - Limitations 의 File Size 2G 입력

기타 추가 설정 : http://pyd.io/administrator/

문제 해결

설정 > Global Configuration > Plugins > Access

Mailbox(Imap or POP) 에러가 발생

php5-imap 확장 설치

sudo apt-get install php5-imap

폴더 다운로드 할때 한글 들어 있는경우 깨질때 해결법

core/classes/pclzip.lib.php 파일에서 $p_header['flag'] = 0; 부분을 찾아서 값을 아래와 같이 2048 로 하면 된다. <

$p_header['flag'] = 2048;

출처 : https://kldp.org/node/140157



댓글을 달아 주세요

티스토리 툴바